Access to TARGET 2.0
Incident Report for Echobot Media Technologies GmbH
Resolved
We were able to solve the issue. TARGET is now accessible again. Thank you for your patience.
Posted Feb 23, 2023 - 09:42 CET
Identified
TARGET is currently not accessible. We are already working on solving the issue.
Posted Feb 23, 2023 - 09:18 CET
This incident affected: TARGET 2.0.