TARGET 2.0 | Difficulties with the website search
Incident Report for Echobot Media Technologies GmbH
Resolved
We were able to solve the issue. You can now use the website search again. Thank you for your patience.
Posted Mar 13, 2023 - 15:51 CET
Identified
There are difficulties with using the website search. We are already working on solving the issue.
Posted Mar 13, 2023 - 15:03 CET
This incident affected: TARGET 2.0.