TARGET 1.0 | Data is loading slowly
Incident Report for Echobot Media Technologies GmbH
Resolved
We were able to solve the issue. Search results of companies are loading as fast as usual again. Thank you for your patience.
Posted Mar 09, 2023 - 12:37 CET
Identified
Currently, search results are loading slowly. We are already working on solving the issue.
Posted Mar 08, 2023 - 12:34 CET
This incident affected: TARGET and TARGET 2.0.